MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000008Liberty UnleashedOtherpublic2011-09-10 21:432013-07-10 12:37
ReporterStormeus 
Assigned ToJuppi 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.1.0.10 
Target VersionFixed in Version0.1.0.11 
Summary0000008: [Request] player.Train, player.InTrain
DescriptionSince 0.1.0.11 is going to support train IDs, it would be useful to have two new player class members:

- player.Train returns the ID of the train the player is in, if they are in one
- player.InTrain a boolean specifying if the player is in a train or not
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000005)
Stormeus (developer)
2011-09-10 21:44

Don't mind me, just setting to Feedback instead of New
(0000007)
Juppi (administrator)
2011-09-10 23:53

I will add something to return train IDs (such ash Player.Train). I don't see the need for Player.InTrain though because the same thing can be achieved by checking whether the train ID is a valid one.

Ideally we'd want to treat trains like any vehicles, however due to how things are synced currently this is not possible yet. It is possible that a later release might replace train IDs with pointers for the sake of consistency, this will obviously be notified beforehands.
(0000011)
Juppi (administrator)
2011-09-11 22:03

The next update will introduce Player.Train (both client-and serverside) which returns the ID of the train or INVALID_TRAIN_ID if the player is not in a train.

- Issue History
Date Modified Username Field Change
2011-09-10 21:43 Stormeus New Issue
2011-09-10 21:44 Stormeus Note Added: 0000005
2011-09-10 21:44 Stormeus Status new => feedback
2011-09-10 23:53 Juppi Note Added: 0000007
2011-09-10 23:53 Juppi Assigned To => Juppi
2011-09-10 23:53 Juppi Status feedback => assigned
2011-09-11 22:03 Juppi Note Added: 0000011
2011-09-11 22:03 Juppi Status assigned => closed
2011-09-11 22:03 Juppi Resolution open => fixed
2011-09-11 22:03 Juppi Fixed in Version => 0.1.0.11
2011-09-12 00:55 Juppi Status closed => resolved
2013-07-10 12:37 Stormeus Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker